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LiDAR Data Extraction 
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QGIS Installation 
To start with you need QGIS.  This is a free download. 

https://qgis.org/en/site/forusers/download.html 

The current version is 3.12 and is the one used for this document. 

Once you have QGIS loaded you should set up some plug-ins.  These are extra features which will 

help you as you review the data.  Start QGIS and click on the ‘Plugins’ option of the main menu and 

select ‘Manage and Install Plugins…’.  This dialog box will appear. 

 

Scroll down the list and install QuickMapServices and QuickOSM. 

  

https://qgis.org/en/site/forusers/download.html
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Obtaining LiDAR data 
Go to the DEFRA website - https://environment.data.gov.uk/DefraDataDownload/?Mode=survey 

Use your mouse to navigate to the grid square containing the area of interest. 

In the ‘Download your data’ window scroll down and locate the drawing tool.  I normally use the 

polygon tool.   

 

In the map window draw a shape round the area of interest (here I am looking at Western Park in 

Leicester). 

In the ‘Download your data’ window click on ‘Download data’. 

The window will display a list of available files. 

https://environment.data.gov.uk/DefraDataDownload/?Mode=survey
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In the product box select ‘National LiDAR Programme DTM’, select the latest year and 1m resolution.   

The National Programme is the latest data.  

The available tiles appear at the bottom of the box. You need all the tiles for your area.  For example 

Western Park is in 2 grid squares so two tiles are required.  Click on each tile to download it.  These 

files are large so ensure you are not using mobile data. 

Repeat with the DSM files. 

The downloaded files are zip files each containing a large TIF file containing the LiDAR data.  Extract 

the files into your working folder 
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Processing the Data 
Start QGIS 

Start a new project and save the project file (e.g. with your data). 

Click ‘Project/Properties’ in the top bar and this dialogue will open … 

Select ‘OSGB1936/British National Grid – ESPG:27700’ and click on ‘OK’. 

Bring the first DTM layer in as a raster layer.  Click ‘Layer/Add Layer/Add Raster Layer’ in the top bar 

or Ctrl + Shift + R. 

This dialog box will appear: 

Use the ‘…’ box to bring up the file selection dialog.  Select one of the DTM TIF files. 

Click the ‘Add’ button 

The Grid transformation window will open.  Accept the transformation offered and click OK 

Watch the progress bar at the bottom as the data is processed. 

Repeat the ‘Add’ process to add the DSM layer. 

You now have two raster layers in the QGIS tool. 
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Note that you can also ‘drag and drop’ the TIF file into the QGIS window and it will open and create 

the raster layer.  You may also be able to do this with the uploaded zip file. 

 

Try unticking the layers to see the monochrome image. 

To see a map of the area under your image select ‘Web’ from the top menu folllowed by ‘QuickMap 

Services’ then ‘OSM’ and ‘OSM Standard’.  This enables the OpenStreetMap layer which can be 

switched on and off as any layer as shown below. 
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Isolate the data for your map area 
To save repetitive operations and lengthy operations it is advisable to join the tiles together and 

then crop to the area you are working on. 

Merging tiles 
For example, Bradgate spans two tiles.  From the top menu select ‘Raster’, ‘Miscellaneous’, ‘Merge’. 

 

In the ‘Input Layers’ click the ‘…’ button to open the ‘Multiple selection’ dialog.  Select the raster 

layers you wish to merge. 

Set the ‘Merged’ output file you wish to use. (if you don’t do this the merged file will go as soon as 

you close the QGIS session. 

Click on the arrow to the left of ‘Advanced Parameters’ to show the extra settings. Set the ‘nodata’ 

value to 0 as shown below. 

 

Click the ‘Run’ button and wait for the processing to complete before clicking the ‘Close’ button. 

Repeat this process for the DSM layer tiles.  It helps to give the new merged layers meaningful 

names in the list on the left hand side.  You will now have a merged DTM layer and a merged DSM 

layer.  Save the project. 
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Cropping the map 
Obtain the area files from the LEI mapping group.  These are vector files of LEI orienteering areas. 

(All files need to be in the same folder - .shp is the shape file but the .dbf & .shx are needed to make 

it work).  

 

Open the LEI_Areas.shp file as a new vector layer 

This screen shot shows the ‘Bradgate’ example overlaid with the LEI_Areas shapes 

As you can see all the areas are shown.   
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Ensure the LEI Areas is the currently selected layer (highlighted in the layer list on the left).  From the 

‘View’ top bar menu select ‘Show Map Tips’ (also available as an icon on the next menu bar down).  

Now when you hover the mouse cursor over an area the area name will appear.  If this does not 

occur right click on the layer in the list on the left and select ‘Properties’.  Select the ‘Display Name’ 

page (The  icon bottom left) and ensure the field ‘Name’ is selected to display.  See below. 

 

 

If you feel so inclined you can have a each area permanently displayed.  In the same properties 

screen go the Labels page ( ).  Set the ‘Value’ field to ‘Name’as shown below. 
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The next step is to select the area shape you wish to use.   

Two methods are available: 

Select by name 
Each area has been named.  In the left hand QGIS window right click on the ‘LEI_Shapes’ layer and 

select ‘Open Attribute Table’.  This brings up a dialog box with the area names.  Scroll through the 

list to find the area you require and left click on the line number.  The example below shows the 

selection of the Bradgate area which is now highlighted in yellow. 

 

Select by cursor 
Left-Click on the select using cursor icon 

Click on the area you wish to use and it will be highlighted.  (if you open the attribute table as 

described above the name of the area you have highlighted will be selected) 

The area you wish to use should now be highlighted.  If the area you wish to use is new or not 

defined refer to appendix 1 on creating/editing a shape file 
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From the QGIS menu select Raster / Extraction / Clip Raster by Mask Layer.  The dialog box below 

will appear. 

Pull down the Input layer list by clicking on the arrow at the right end of the dialogue box.  Select the 

merged layer you wish to crop (It is here that sensible layer naming becomes and advantage). 

Pull down the Mask layer list by clicking on the arrow at the right end of the dialogue box.  Select the 

LEI-Areas layer.  Double click this dialog box to allow you to select the ‘selected features only’ tick 

box. 

Finally scroll down to ‘Advanced Parameters’ and set the output file.  Click on the ‘…’ button on the 

right and select ‘save to file’.  In the standard file dialog you will name the TIF output file. 

Click the ‘Run’ button and allow the process to complete (it may take some time). 

Click ‘Close’ when the process finishes.  The cropped TIFF file will be shown as a new layer.  Give the 

new layer a descriptive name.  Untick the other areas to show the new cropped layer. The areas 

outside the selected area may show as black. 

 

Repeat the process for DTM and DSM layers. 

As an alternative see Apendix A – Creating Your own Shape file  
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Extract the contours 
In the layer list on the left of the QGIS desktop select the merged and cropped DTM layer. 

From the ‘Raster’ menu select ‘Extraction’ / ‘Contour’.  The following dialogue will appear: 

Set the interval between contour lines.  It is suggested that you use a smaller gap that the final map 

so that intermediate detail can be mapped using form lines.  I tend to use 1m contours. 

Scroll down to the ‘Advanced Parameters’ and click the small arrow to show the extra features.  Set 

the ‘Input pixel value to treat as “nodata”‘ to 0.  This prevents a border round the contour plot. 

Move down to ‘Contours’ and set the output file.  It is recommended that the file is stored as a 

‘.SHP’ file.  This file can be read directly by OpenOrienteer Mapper. 

Click ‘Run’.  Allow the process time to run: 

You will now see the contours added to the list of layers.  Give the layer a sensible name. 

 

NB for use in older versions of Ocad you will need to export as a DXF file.  Ensure the ‘Attribute 

name’ field is clear before running conversion. 

  



Page 12 of 18 Version 3 18/03/2021 

Switch off the other layers to see the generated contours. 

The resulting georeferenced SHP file can be imported into Ocad or used as a template in OOM. 
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Extracting Vegetation Boundaries 
The vegetation can be deduced by subtracting the DTM layer from the DSM layer leaving a result 

that shows the height above the ground level. 

Select ‘Raster’ / ‘Raster Calculator’. 

 

To set up the process use the ‘…’ button to setup an output file. 

The X/Y values have been set up to process only the area of interest.  Theses value can be worked 

out from the main screen before initiating this window (move the cursor and observe the 

coordinates bar at the bottom of the screen).  In this instance the Western Park area has been 

selected. 

To set up the expression first in the ‘Raster Bands’ window double click on the DSM layer, then click 

on the ‘-‘ button, finally double click on the DTM layer.  This will generate the expression as shown in 

the screen shot above.  Click ‘OK’ to generate the output as a new raster layer. 

Once the raster layer has generated extract the layer contours as before to generate a SHP file that 

can be brought into the mapping program. 
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Importing the contours into OOM. 
This method assumes you already have a georeferenced OOM map of the area and are going to use 

the LiDAR data to update/correct the map. 

Open the map and open the template setup window (Templates/Open Template Setup Window 

from the main menu or Ctrl+Shift+9. 

From the main menu select Templates/Open Template (or click the  icon in the template 

window).  Select the .SHP file created earlier.  Accept the default settings offered by the dialogue 

box.  The contours will now appear as a template beneath your map.  When working with templates 

set the opacity in the Template Setup Window to 50% so you can see the contours through the map. 

 

Note that we have imported contours here at 1m intervals and the final map only needs 5m 

contours.  This allows the mapper to select the contour lines that best express the landscape.  The 

mapper can also use the intermediate contours to create form lines to fill in missing detail.  It is 

permissible to slip up or down a contour across the map if it helps paint a better picture for the 

orienteer. 

Make sure the final map has the environment agency copyright notice acknowledging the use of the 

LiDAR data. 

 

Use the date of the data in the copyright notice. (Up to date copyright symbols are available in the 

Mapping Resources on the BOF website 

https://www.britishorienteering.org.uk/mapping_resources) 

 

https://www.britishorienteering.org.uk/mapping_resources
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Creating a new OOM map 
Once you have generated the LiDAR extract for your area it can be used to create a georeferenced 

OOM map. 

Start your OOM application.  From the opening screen select ‘Create a new map’. 

 

This dialog box will now open. 

Choose the map scale you wish to use and the symbol sets available for that scale will be displayed.  

So in this example we are setting out to draw a map at 1:10,000 using the ISOM2017-2 symbol set.  

The symbol sets have been drawn in conjunction with the IOF mappers so the symbols and colours 

are to specification.  Select ‘Create’ to open your new map. 

 

Here you can see the symbol set and some hints to get going.  The next step is to use your LiDAR 

extract as the base map. 
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Click on ‘Templates’ and select ‘Open Template’.  Select the .shp LiDAR contour file that you created 

earlier. 

OOM recognised that this is the first base map and uses it to derive the georeferencing.  This screen 

will open: 

 

Ensure the ‘Coordinate Reference System’ and the ‘ESPG code’ are as shown above 

Versions of Mapper up to and including 0.9.2 require a correction.  The ‘Coordinate Reference 

System’  should be set to ‘Custom PROJ.4’ .  The ‘Specification’ field should be replaced with the one 

below (include all the text in italics). 

+proj=tmerc +lat_0=49 +lon_0=-2 +k=0.9996012717 +x_0=400000 +y_0=-100000 +ellps=airy 

+datum=OSGB36 +units=m +no_defs 

 

 

Move onto the Map North settings.  In the Declination field the angle between true north and 

magnetic north at the position of the map has to be entered to make magnetic north be at the top. 

Your map should be orientated to magnetic north, not grid north.  Click the ‘Lookup’ button.  This 

uses the current georeferenced coordinates to find out the magnetic deviation from grid.  This opens 

a page in your web browser.  Copy the value displayed into the ‘Declination box’. 

Declination positive values are east of true north and negative values are west of true north. 
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Click ‘OK’ and you are ready to start drawing your georeferenced map. 
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Appendix 1 – Creating/Editing a shape file. 
Shapefiles describe vector features. Vector data provides a way to represent real world features 
within the GIS environment. A vector feature has its shape represented using geometry. The 
geometry is made up of one or more interconnected vertices. A vertex describes a position in space 
using an X, Y axis. 

First, zoom in to the area where your area of interest. Choose Layer→ Create Layer→  New 
Shapefile Layer from the Layer menu (or the same button on the toolbar). The New Vector Layer 
dialog will be displayed. Choose the type of layer "polygon".  In the Fields List, select "id", and click 
the button [Remove Field]. Under New Field, type a name (e.g., "my_polygons"), click on [Add to 
Fields list], and then click [OK]. You will be prompted to the Save as dialog. Type the file name 
("my_polygon") and click [Save]. You will be able to see the new layer in the Layers list. 

Click on the layer name to select the layer you have just created. All editing sessions start by 

choosing the  Toggle editing option (either on the toolbar or under the Layer menu). Select this 
option and note that the little pencil symbol will show up beside the name of the layer, indicating 

that the layer is now editable. Now, click on the  Add Feature icon (or select Edit →  Add 
Feature). When you do this, the cursor will look different (not an arrow head). Left-click on the map 
area to create the first point of your new feature. Keep on left-clicking for each additional point you 
wish to include in your polygon. When you have finished adding points (i.e., the polygon represents 
the desired operational area), right-click anywhere on the map area to confirm you have finished 
entering the geometry of that feature. The attribute window will appear. Input the name you want 

for your polygon (e.g.,"polygon1"), and click [OK]. Then, click on  Save Layer Edits (either on the 
toolbar or under the Layer menu). 

 


